码库记事本

码库记事本

apache 支持 php5 的配置方法

小诸哥 0
httpd.conf下让apache 支持 php5 的配置
1.下载apache安装包,并执行安装。
2.下载php5的zip包,并解压到c:\php
3.修改apache的配置文件httpd.conf,添加以下:
代码如下:

#load the php main library to avoid dll hell
Loadfile "C:\php\php5ts.dll"
#load the sapi so that apache can use php
LoadModule php5_module "C:\php\php5apache2_2.dll"
#set the php.ini location so that you don't have to waste time guessing where it is
PHPIniDir "C:\php"
#Hook the php file extensions, notice that Addtype is NOT USED, since that's just stupid
AddHandler application/x-httpd-php .php
AddHandler application/x-httpd-php-source .phps


4.如果出错,则将php目录下的dll 复制到c:\windows\system32目录。

标签: apache php5